مشکل در تکسچر دادن مدلی که از c4d به element3d میارم

zabih
تصاویر zabih
Offline
عضو شده در: 1393/04/19

با سلام من هر وقت مدلی رو که تو c4d انیمیت کردم و با Plexus OBJ Exporter خروجی میگیرم و مدلمو رو به صورت 3d sequens وارد المنت میکنم . نمیتونم تکسچرهاشو به خورد مدل بدم لطفا کمک کنید

شاهرخ جهان زاده
تصاویر شاهرخ جهان زاده
Offline
عضو شده در: 1391/01/09
سلام این مشکل میتونه دلیلش

سلام
این مشکل میتونه دلیلش استفاده از همین پلاگینی باشه که شما برای خروجی گرفتن استفاده میکنید.
پلاگین Plexus OBJ Exporter مشکلات زیادی داره که هنوز بر طرف نشده به عنوان مشکل Normal کردن رو داره که در هنگام خروجی گرفتن نمیتونه اون رو به مدل بده و برای رفع اون میتونید از گزینه Auto Normal در خود پلاگین Element استفاده کنید و مقدار Edge Threshold رو تغییر بدید تا به نتیجه برسید. البته این گزینه بیشتر برای رفع مشکل Shading هست.
*** به این نکته مهم دقت کنید که پلاگین Plexus OBJ Exporter اطلاعات Normal رو خروجی نمیگیره چون به نوعی برای کار با پلاگین Plexus در Ae ساخته شده و بیشتر تمرکز این پلاگین روی خروجی گرفتن اطلاعات نقاط هست ولی پلاگین Element به تمامی اطلاعات بسیار دقیق و مهم Polygonها در فایل های OBJ نیاز داره. پس استفاده از اون رو فراموش کنید...

بهترین راه حل استفاده از پلاگین Riptide Pro برای C4D هست. اون رو نصب کنید و به منوی Plugin در نرم افزار C4D برید، بعد از اون به بخش Riptide Pro مراجعه کنید و گزینه .Obj Exporter رو انتخاب کنید. نیاز به تنظیمات چندانی ندارید ولی چند نکته رو رعایت کنید. اول مطمئن باشید تیک مربوط به گزینه Animation Sequence در تب File(s) زده شده باشه. دوم: به تب Filter برید و گزینه Export Normals رو حتما فعال کنید و در نهایت روی Ok کلیک کنید و مسیر مورد نظر رو برای ذخیره معرفی کنید...
مشکل به احتمال بالای 99% حل خواهد شد